It is currently Thu Nov 15, 2018 7:54 am




Post new topic Reply to topic  [ 21 posts ]  Go to page Previous  1, 2
Mems3 diagnostic socket 
Author Message
On the Road

Joined: Mon Jul 13, 2015 6:32 pm
Posts: 535
GTM: Libra
Post Re: Mems3 diagnostic socket
Hi all,

So thanks to your help, I wired an earth into the diagnostic socket and then the reader fired up no problem. Only problem is that is says that it can’t communicate with the engine? I’ve checked the continuity of the ECU communication wire and it’s all in order.....??

The reader is only a cheap eBay jobbie....could this be the problem? Any recommendations for an OSB2 reader that works with the mems3 unit?

I’m the meantime I’ve taken off the VVC unit solonoids and tested them and they’re working fine, I have power to the solonoids when the ignition is on and I’ve traced the signal wires for all 3 plugs back to the ECU and they’re all going to the correct pins so nothing untoward there....

Next job is to swap the cam sensor and oil temp sensor for new ones to eliminate them and then take a look at the VVC unit and mechanical cam timing if it’s not those. Other than that I can only think it’s an ECU problem but hopefully not.

If I could get the OSB2 reader to work this would’ve been a lot easier :roll:


Wed Oct 24, 2018 8:52 pm
Profile E-mail
On the Road

Joined: Mon Jul 13, 2015 6:32 pm
Posts: 535
GTM: Libra
Post Re: Mems3 diagnostic socket
Thankfully, it turned out to be a faulty cam position sensor, fitted a new one yesterday and it’s working perfectly.

Still no joy with the OSB2 reader though :(


Sun Oct 28, 2018 7:42 am
Profile E-mail
On the Road
User avatar

Joined: Sun Oct 19, 2014 10:10 pm
Posts: 743
Location: Bristol
GTM: Spyder
Post Re: Mems3 diagnostic socket
Jaykart1227 wrote:
Thankfully, it turned out to be a faulty cam position sensor, fitted a new one yesterday and it’s working perfectly.
:(


Glad it was a relatively easy fix. And I guessed right! :mrgreen:


Sun Oct 28, 2018 2:26 pm
Profile E-mail
Ready for SVA

Joined: Wed Aug 11, 2010 9:27 am
Posts: 393
Location: Sheffield
GTM: Libra
Post Re: Mems3 diagnostic socket
Funny how you find things after the fact... https://www.youtube.com/watch?v=TmHtTPu ... nel=yamkiy

_________________
2000 GTM Libra 1.8VVC 145BHP


Sun Oct 28, 2018 3:05 pm
Profile E-mail
On the Road

Joined: Mon Jul 13, 2015 6:32 pm
Posts: 535
GTM: Libra
Post Re: Mems3 diagnostic socket
sanzomat wrote:
Jaykart1227 wrote:
Thankfully, it turned out to be a faulty cam position sensor, fitted a new one yesterday and it’s working perfectly.
:(


Glad it was a relatively easy fix. And I guessed right! :mrgreen:


You did indeed Dave.......gonna start referring to you as the 'k series whisperer'........

Thanks for all the suggestions everyone.


Sun Oct 28, 2018 5:59 pm
Profile E-mail
On the Road

Joined: Mon Jul 13, 2015 6:32 pm
Posts: 535
GTM: Libra
Post Re: Mems3 diagnostic socket
sidewinder wrote:
Funny how you find things after the fact... https://www.youtube.com/watch?v=TmHtTPu ... nel=yamkiy


I thought I'd looked at everything YT had to offer on the matter but I managed to miss that one.....Doh!


Sun Oct 28, 2018 6:00 pm
Profile E-mail
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ]  Go to page Previous  1, 2


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.

phpBB SEO