GTM Owners Club Forum
https://www.gtmdrivers.com/forum/

VVC Running rich - Lambda?
http://www.gtmdrivers.com/forum/vvc-running-rich-lambda-t3445.html
Page 1 of 1

Author:  sanzomat [ Fri Apr 08, 2016 7:31 am ]
Post subject:  VVC Running rich - Lambda?

My Spyder seems to be running a bit on the rich side (1.8 VVC K series, Mems2.0). The exhaust is looking sooty and a friend noted the smell when he followed me. As its a standard ecu with all the standard sensors its unlikely to be a mapping issue, more likely to be a sensor and my first thought is the lambda. Various k-series forums suggest the Lambda does go and is the most common reason for a MOT emissions fail. As this engine was an ebay buy taken out of a MOT failure MGF I can't be sure of its history and has only been in the car a few weeks and had been like this the whole time. I had a problem with the HT leads so when I first ran it it was very rough and letting unburnt fuel down the exhaust so may have upset the lambda even if it was okay before (which may be doubtful). There is no cat.

Only £35 for a new lambda so thinking I'll try that.

Any thoughts?

Author:  Tim Rowe (1130) [ Fri Apr 08, 2016 8:21 am ]
Post subject:  Re: VVC Running rich - Lambda?

I'd certainly try the lambda to try and rule it in or out. I run mine with a cat, as it failed the mot without and actually seems to be happier with it. :D

Author:  Libra_134 [ Fri Apr 08, 2016 11:50 am ]
Post subject:  Re: VVC Running rich - Lambda?

I'm no expert but are there any holes in the exhaust system?

I was failing on emissions at my last MOT and it was only after hooking up the smoke machine to the exhaust we found a tiny pin prick hole in one of the welds on the manifold. It wasn't big at all but it was enough to throw the Lambda sensor reading out. :evil:

The smoke test revealed a couple of other leaks in the exhaust where the exhaust bracket is sandwiched between the pipes... not the best really, the garage was suggesting other ways to do it but I don't have time or energy to go mucking about with it!! :lol:

Author:  Elansprint [ Fri Apr 08, 2016 3:47 pm ]
Post subject:  Re: VVC Running rich - Lambda?

It would be worth finding out the resistance for the water temperature sensor and the air inlet temperature if one of these has failed it will confuse the ecu when you have the values simple resistance measurement to check
Ian

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/